Running MSDOS programs in XP

Text-only Version: Click HERE to see this thread with all of the graphics, features, and links.



~Sir Mist~
Anyone know how the feck Im supposed to run an MSDOS based program in Windows XP?

What kind of idiots decided to remove MSDOS from XP?

So yeah, I have programs I cant run...any way to emulate them or something?

Ushgarak
You can kinda try running them with all sorts of tweaks and stuff- including setting simulated EMS and XMS levels, and so forth- but i doesn't always work right.

So for a DOS emulator, try DOBbox (google it).

Clovie
in program properities is that thing....
in polish it's called 'zgodność' (sorry) and it has there option to make that program open in acceptance (?) with win NT, DOS or whatever confused

Raz
DOS programs are compatiable with WinXP - as long as it doesn't access hardware direcly e.g. a BIOS updater.

If its a simple program or game, then Start->Run and type in 'cmd' or if you want the original DOS (much slower) type in 'command'

~Sir Mist~
Originally posted by Ushgarak
You can kinda try running them with all sorts of tweaks and stuff- including setting simulated EMS and XMS levels, and so forth- but i doesn't always work right.

So for a DOS emulator, try DOBbox (google it).

Havent tried this yet, but so far it looks like the only option left to do...

Originally posted by Clovie
in program properities is that thing....
in polish it's called 'zgodność' (sorry) and it has there option to make that program open in acceptance (?) with win NT, DOS or whatever confused

I tried this, it still wont open sad

Originally posted by Raz
DOS programs are compatiable with WinXP - as long as it doesn't access hardware direcly e.g. a BIOS updater.

If its a simple program or game, then Start->Run and type in 'cmd' or if you want the original DOS (much slower) type in 'command'

Tried the cmd thing, it still wont run..sad

When I open it normally, it says

"C: \Windows\SYSTEM32\AUTOEXEC.NT. The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose 'Close' to terminate the application"

BakaXero
http://www.dosgames.com/xphints.php#4
this site might help. part 4 worked out my problems

Archer
CermWindows\System32\Autoexec.nt The system file is not suitable for running MS-DOS and Microsoft Windows applications. Choose 'Close' to terminate the application.
Although you may be prompted to quit the program or ignore the error message, either selection makes the program quit.
CAUSE

This issue may occur if one or more of the following files are missing or damaged:
Config.nt
Autoexec.nt
Command.com

RESOLUTION
To resolve this issue: 1. Insert the Winxp CD into the CD drive or DVD drive.
2. Click Start, and then click Run.
3. In the Open box, type cmd, and then click OK.
4. At the command prompt, type the following commands, pressing ENTER after each command:


expand CD-ROM Drive Letterermi386\config.nt_ cermwindows\system32\config.nt
expand CD-ROM Drive Letterermi386\autoexec.nt_ cermwindows\system32\autoexec.nt
expand CD-ROM Drive Letterermi386\command.co_ cermwindows\system32\command.com
exit
5. Start or install the program. If the issue is resolved, do not complete the remaining steps. If the issue is not resolved, go to the next step.
6. Note: The Command.com file is not edited or created in this in the following process. Because of this, you may have to expand it from your Windows XP CD-ROM.

Start Notepad.
7. In Notepad, type the following entries: dos=high, umb
device=%SYSTEMROOT%\system32\himem.sys
files=40

8. On the File menu, click Save As.
9. In the File Name box, type Config.nt, and then click Save. Close the Config.nt file.
10. On the File menu, click New.
11. In the new blank document, type the following entries: @echo off
lh %SYSTEMROOT%\system32\mscdexnt.exe
lh %SYSTEMROOT%\system32\redir
lh %SYSTEMROOT%\system32\dosx
SET BLASTER=A220 I5 D1 P330 T3

12. On the File menu, click Save As.
13. In the File Name box, type Autoexec.nt, and then click Save. Close the Autoexec.nt file.
14. Start Windows Explorer. Locate the Config.nt file, right-click the Config.nt file, and then click Copy.
15. Right-click the %SYSTEMROOT%\System32 folder, and then click Paste.
16. Locate the Autoexec.nt file, right-click the Autoexec.nt file, and then click Copy.
17. Right-click the %SYSTEMROOT%\System32 folder, and then click Paste.
18. Locate the Command.com file, right-click the expanded Command.com file, and then click Copy.
19. Right-click the %SYSTEMROOT%\System32 folder, and then click Paste. Restart your computer.
If the issue continues to occur, copy the Autoexec.nt and Config.nt files from the Repair folder in Windows to the System folder. To do so, follow these steps: 1. Click Start, click Run, type cermwindows\repair, and then click OK.
2. Right-click autoexec.nt, and then click Copy.
3. Click Start, click Run, type cermwindows\system32, and then click OK.
4. Right-click anywhere in that folder, and then click Paste.
5. Right-click the Autoexect.nt file that you just copied, and then click Properties.
6. Click to select Read-Only, and then click OK.
7. Repeat steps 1 through 6 to copy the Config.nt file.
Note You must enable Read-Only permissions or the files will be removed after you restart Windows.

Text-only Version: Click HERE to see this thread with all of the graphics, features, and links.